BRT Community

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to the Bridgetek Community!

Please read our Welcome Note

Technical Support enquires
please contact the team
@ Bridgetek Support

Please refer to our website for detailed information on all our products - Bridgetek - Bridging Technology

Author Topic: ESD EvChargePoint demo not working on ESD 4.15.1 or 4.8  (Read 224 times)

Louis Cloete

  • Newbie
  • *
  • Posts: 6
    • View Profile
ESD EvChargePoint demo not working on ESD 4.15.1 or 4.8
« on: September 28, 2022, 12:23:50 PM »

Hi

I'm not getting the EvChargePoint demo to work on either ESD 4.15.1 or 4.8 on the emulator. I'm getting errors during code generation. Do I need any extra tools installed?

I replaced 4.8 with 4.15, since the only reason I had 4.8 is the confusing structure of the FTDI/Bridgetek website migrations.

I can post my errors if necessary.
Logged

BRT Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 625
    • View Profile
Re: ESD EvChargePoint demo not working on ESD 4.15.1 or 4.8
« Reply #1 on: September 28, 2022, 02:06:40 PM »

Hello,

Thank you for your question.

I would suggest completely uninstalling both versions on ESD from your machine, then re-installing ESD 4.15.1 just to ensure there are no conflicts in the installation. No other toolchains should be required to run the ESD toolchain.

Once you have completed this step, please share any error messages you may be generating during compilation of the project.

Best Regards,
BRT Community
Logged

Louis Cloete

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: ESD EvChargePoint demo not working on ESD 4.15.1 or 4.8
« Reply #2 on: September 29, 2022, 10:25:36 AM »

I did a complete reinstall of 4.15 and made sure to not accidentally change any settings prior to first building the project as-is. That solved my issue. I think I must have changed some setting accidentally. I do think it's much too easy to accidentally change something, but the example is working now in the emulator.
Logged

BRT Community

  • Administrator
  • Hero Member
  • *****
  • Posts: 625
    • View Profile
Re: ESD EvChargePoint demo not working on ESD 4.15.1 or 4.8
« Reply #3 on: September 29, 2022, 04:47:32 PM »

Hello,

Thank you for the update, glad to hear you have the project up and running now!

Please let us know if you have any further queries.

Best Regards,
BRT Community
Logged

Louis Cloete

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: ESD EvChargePoint demo not working on ESD 4.15.1 or 4.8
« Reply #4 on: September 29, 2022, 08:04:38 PM »

I got the demo working with MPSSE and FTDI cable, and then successfully ported to STM32L476RG.
Logged